Music Banter

Go Back   Music Banter > Artists Corner > Stereo & Production Equipment
Register Blogging Search Today's Posts Mark Forums Read
Welcome to Music Banter Forum! Make sure to register - it's free and very quick! You have to register before you can post and participate in our discussions with over 70,000 other registered members. After you create your free account, you will be able to customize many options, you will have the full access to over 1,100,000 posts.

Reply
 
Thread Tools Display Modes
Old 03-29-2013, 01:51 PM   #1 (permalink)
Music Addict
 
XtremeEclectic's Avatar
 
Join Date: Mar 2013
Location: SC
Posts: 67
Default Old School Tech Corner

So I figured what the heck I will throw a post up if anyone has any tech questions, repair questions, need help with vintage gear, Want to ask about that old reciever in grandma's attic well shoot it out here

Not saying im the definitive source for this but rather knowledgable and would love to help ya'll out!

There are no stupid questions by the way, so feel free just keep within topic please.
XtremeEclectic is offline   Reply With Quote
Old 04-04-2013, 03:33 PM   #2 (permalink)
Music Addict
 
XtremeEclectic's Avatar
 
Join Date: Mar 2013
Location: SC
Posts: 67
Default

Wow 96 views, no questions. Interesting I take it there is not a ton of older gear floating around anyones listening spaces at the moment?
XtremeEclectic is offline   Reply With Quote
Old 10-11-2016, 06:04 PM   #3 (permalink)
Groupie
 
Join Date: Oct 2016
Posts: 1
Default hi....about jvc cx5

Hi...are you the guy...oldschooltechcorner...doing the very interesting you tube Walkman repairs...thanks for the great videos...i see you have repaired the above jvc....also I have one that everything works except it only plays for 10-20 seconds before it stops...usually/ sometimes it has begun to chew the tape also...could it be the belt?
If so ..your opinion...and cost of repair service etc
Thanks again
Mark from australia
siva22 is offline   Reply With Quote
Old 10-26-2016, 07:22 PM   #4 (permalink)
Groupie
 
Join Date: Oct 2016
Posts: 17
Default

More than likely it isn't the belt. Probably something not engaging all the way. When I worked at This Audio Engineering School I had to repair all of their decks. It was a mess.

Last edited by radkins; 10-27-2016 at 02:04 PM.
radkins is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Similar Threads



2003-2019 Advameg, Inc.

SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.